当前位置:首页 > wifi设置知识 > 正文内容

路由选择协议有哪些

秋天2023年03月20日 05:54:08wifi设置知识451

无线网络连接对于现代生活非常重要,本文路由选择协议有哪些将教你如何正确设置路由器和Wi-Fi,避免网络问题的发生。

本文内容目录一览:

常见的路由协议都有哪些?

常用的Internet路由协议有RIP、OSPF、IS-IS、IGRP、EIGRP、BGP等

在连接情况较简单的网络结构中,相连的路由器也可以不采用动态的路由协议,而直接采用静态的

这些路由协议,在上达中型企业中,可能一般用到的是静态路由,RIP

像OSPF 只是到达超大的路由环境才会用到.

RIP路由选择协议

典型的路由协议有rip,ospf,isis,bgp等。rip是用经过的路由器跳数来衡量的,最少的跳数就是最优路由。

RIP共有三个版本,RIPv1, RIPv2, RIPng

其中RIPV1和RIPV2是用在IPV4的网络环境里,RIPng是用在IPV6的网络环境里。 因为RIPv1的缺陷,RIPv2在1994年被提出,将子网络的资讯包含在内,透过这样的方式提供无类别域间路由,不过对于最大节点数15的这个限制仍然被保留着。另外针对安全性的问题,RIPv2也提供一套方法,透过加密来达到认证的效果。而之后[RFC 2082 ]也定义了利用MD5来达到认证的方法。 RIPv2的相关规定在[RFC 2453 ] orSTD56。

现今的IPv4网络中使用的大多是RIPv2,RIPv2是在RIPv1基础上的改进, RIPv2和RIPv1相比主要有以下区别。

RIPng(Routing Information Protocol next generation)则被定义在[RFC 2080 ],主要是针对IPv6做一些延伸的规范。与RIPv2相比下其最主要的差异是:

RIPv2 支持RIP更新认证, RIPng 则没有 (IPv6 routers were, at the time, supposed to use IPsec for authentication);

RIPv2 容许附上arbitrary 的标签, RIPng 则不容许;

RIPv2 encodes the next-hop into each route entries, RIPng requires specific encoding of the nexthop for a set of route entries.

RIPv2 UDP的Port number 为 520,RIPng UDP的Port number 为 521

路由协议有哪些

路由协议有:

1、RIP协议-路由信息协议,属于最早的动态路由协议优点:节约成本,对资源消耗较低,配置简单,对硬件要求低,占用CPU、内存低,所以在小型网络中还有使用到。缺点:计算路由慢,链路变化了收敛慢,能够保存的路由表相对较小,最多只能支持15台设备的网络,只适用于小型网络。

2、OSPF协议-开放最短路径优先协议,企业网主要使用的协议优点:技术成熟,碰到的问题基本上在资料上都能够查到,收敛快,由于cisco的力推,会使用的人多缺点:收敛速度,安全性较ISIS差。

3、ISIS协议-中间系统到中间系统协议,传输网/运营商网络主要使用的协议优点:算法与OSPF类似,收敛快,安全性高缺点:异常处理资料不如OSPF丰富。

4、BGP协议-边界网关协议,用于核心网的路由的传递无所谓优缺点,因为它和其他的不重叠,一个简单的应用,比如BGP可以用于网通和电信之间路由的相互传递,如果使用其它IGP(OSPF或者ISIS)的话,会由于路由数量太多,无法计算出来路由,或者路由计算非常慢,可以支持百万级别的路由的计算和传递,对设备要求较高,对资源占用较大。

在使用路由器时,这些技巧将有助于提高您的网络性能,并使您的网络连接更加可靠和安全。

扫描二维码推送至手机访问。

版权声明:本文由路由设置网发布,如需转载请注明出处。

本文链接:https://www.shoulian.org/luyou/post/15674.html

分享给朋友:

“路由选择协议有哪些” 的相关文章

水星路由器怎么链接网线

水星路由器怎么链接网线

今天给各位分享水星路由器怎么链接网线的知识,其中也会对水星路由器怎么连接网线进行解释,如果能碰巧解决你现在面临的问题,别忘了关注本站 本文内容目录一览: 1、水星无线路由器如何连接光纤猫 2、水星 MW310R 300M无线路由器安装教程(最好有图文教程) 3、水星无线路由器连接tp lin...

海康路由器怎么连接猫

海康路由器怎么连接猫

今天给各位分享海康路由器怎么连接猫的知识,其中也会对宽带路由器猫怎么连接进行解释,如果能碰巧解决你现在面临的问题,别忘了关注本站 本文内容目录一览: 1、路由器怎么连接猫安装方法 2、路由器怎么连接猫 3、路由器与猫的连接图解 4、路由器怎么跟光猫连接 路由器怎么连接猫安装方法 路由器...

怎么清理路由器模块

怎么清理路由器模块

今天给各位分享怎么清理路由器模块的知识,其中也会对路由器 清理进行解释,如果能碰巧解决你现在面临的问题,别忘了关注本站 本文内容目录一览: 1、cisco 路由器如何清除特定接口ip 2、苹果电脑A1466怎么拆接收路由器模块? 3、路由器模块! 4、路由器用多长时间需要更换? 5、...

路由器电力猫怎么选择

路由器电力猫怎么选择

针对路由器电力猫怎么选择这个问题,本文将综合不同朋友对这个电力猫和无线路由器的知识为大家一起来解答,希望能帮到大家 本文内容目录一览: 1、电力猫效果好不好 wifi放大器对比电力猫怎么选 2、现在用无线电力猫好还是无线路由器 3、如何选购电力猫 4、电力猫和无线路由器哪个好? 5、...

zte路由器怎么重置密码

zte路由器怎么重置密码

针对zte路由器怎么重置密码这个问题,本文将综合不同朋友对这个zte路由器管理密码忘了怎么办的知识为大家一起来解答,希望能帮到大家 本文内容目录一览: 1、zte路由器认证密码忘了怎么办? 2、ZTE中兴的wifi密码怎么修改 3、如何用手机设置ZTE中兴路由的密码? 4、中兴路由器怎样...

路由器怎么会发烫

路由器怎么会发烫

当朋友们看到这个文章时想必是想要了解路由器怎么会发烫相关的知识,这里同时多从个角度为大家介绍路由器发烫是正常的吗相应的内容。 本文内容目录一览: 1、为什么无线路由器那么烫啊 2、路由器使用没几个小时就很烫,是怎么回事儿? 3、无线路由器很烫怎么解决? 为什么无线路由器那么烫啊 无线路由器...